Diablo 4 Beta crash at start up

Every time I start up the beta the logo appears then it crashes 3 secs in. I have scanned all the files again. I have also made sure both my drives and windows are up to date.


Same problem here.

Already tried to verify files, move to another hdd, download again, nvidia update, rebuild WMI Repository and so on… nothing working.

Was able to login in at approximately 1015am MST and after about 30 minutes got booted. Not showing characters in the lobby so I closed D4 client and reopened via Battle.net, now showing 70 minute login queue.


Have the same problem. Trying to download game again. I hope its help.

same problem here ,
GPU driver updated
minimum requirements met
scan and repair done 2-3 times
re-downloaded and re-installed the game
still cannot get past the 3 second crash


Having same issue also.


Got in after 20 min queue, get in interact with firt thing and crash and booted…back to queue only this time over 2 hr queue. Glad I spent $100 for this even if it is Beta that is just plain rude.


Not allowed to link the post i found it in but…

DisableChromaEffects “1”
within Documents\Diablo IV\LocalPrefs.txt fixed the issue for me.

Found this and it worked for me, now sitting in the queue…


Worked for me too. Thank You

Worked for me also. Thank you! I’m also kind of disappointed because this was a problem with diablo3 that they never fixed as well.

you’re the real mvp, thank you

This is absolutely pathetic. Blizzard should have absolutely known this server and crash issue was going to happen. One and half hours and i still cannot get into this game. What is going on there??? I can guarantee the YouTubers aren’t having any problems.

1 Like

I was having the same issue, this 100% fixed it. Not the queue wait, but at least I can actually log in to the game and get into the queue now.


Yup that fixed it for me as well. TY TY you are the GOAT.

Also, im curious, has anybody with this issue actually ever installled razer chroma? I haven’t on this computer, but apparently I had some pieces of razer chroma hanging around.

Dealing with a fix for the crash would be far less of an issue if there weren’t an hour’s wait in queue to try again.

It fixed the startup crash for me, but after 110 minutes of waiting to get into the game, got to the first town of the tutorial and crashed. Back for another hour of waiting to see how much progress it kept. Very, very poor showing even for a Beta.

Why i can’t see localprefs.txt in the game files?

I just copied the file location from his post and pasted it into the file explorer, that should find it for you. Documents\Diablo IV\LocalPrefs.txt

it’s acxtually in a Diablo4-folder under Documents (no matter wehere you put your game). Which is weird - but whatever

You are amazing. Just need to put that out there.