Desktop App/Agent fails to properly download game


#1

Hello. I am trying to install a game, but it does not install as I expect. While game files do eventually download, the blizzard app “front end” fails to recognize these files even after numerous reinstalls.

I want to prefix all of this by saying that a week ago - things were working fine. You guys need to trust me on this when I say I’ve made no explicit changes to my router, and a Windows Update was probably the original cause of me noticing this issue when attempting to install an game update for a favorite game. However, clean installs of Windows 10 Home Edition have not resolved my issue.

I’ve also modified URLs so I can keep the gist of the message, without losing so much info

To replicate:

  1. I installed a fresh copy of Windows 10 Home Edition on my PC. During installation, I made sure to wipe my partition (so, in theory, absolutely NO blizzard files should be on my system). I am on version 10.0.18362 build 18362. I am using the Windows Insider program, on the Slow Ring.

  2. I updated graphics drivers, and updated windows 10 with newest updates. I restarted so that updates could take effect

  3. I ran a administrator command line sfc /scannow and DISM /Online /Cleanup-Image /ScanHealth. Both tools have indicated my operating system is fine and free of corruption.

  4. I have installed NOTHING else. Nothing. Not chrome, not steam, not spotify, not notepad++. I used Microsoft Edge to download the battle net client. I really want to emphasize that I’m trying to provide you guys an incredibly clean slate.

  5. I installed your client, via wwwDOTblizzardDOTcom/en-us/apps/battleDOTnet/desktop. I ran this download through windows CertUtil using an MD5 checksum. I have NOT made any modifications to the desktop app after the install. Again - I want this to be as clean as possible for you guys to investigate. I am running App version 1.15.1.11346, Agent version 2.18.1.6788

MD5 CHECKSUM
PS C:\Users\bacon\Downloads> CertUtil -hashfile .\Battle.net-Setup.exe MD5
MD5 hash of .\Battle.net-Setup.exe: 62c0ae9557b0ceac47e8356a553e2836
CertUtil: -hashfile command completed successfully.

  1. I have installed the client to C:\Program Files (x86). I will use this directory for all installs.

  2. The install automatically started the client. I clicked Diablo III/Destiny 2, and then clicked install. A dialog box opened, and the little loading icon in the bottom right corner spun for around 5 minutes, before allowing me to finally pick where to install Diablo III/Destiny 2. I chose C:\Program Files (x86). The Battle net app closed the dialog box, and sat at the “main window” with the progress bar indicating “waiting…”. This behavior continued for about roughly 20 minutes.

  3. I noticed you have log files for blizzard agent kept in C:\ProgramData. I have made a copy, and attached this log file as Agent-20190817T150055.log on the ticket I originally opened with tech support team. They should have it and be able to provide it. I see that my communications with blizzard services are mostly okay (from someone who has worked with webservices before but knows jack about your systems, these are - admittedly - guesses).

  4. Right at the top of this file I noticed the following:

[I 2019-08-17 15:00:55.0856] Network Connection Response to usDOTpatchDOTbattleDOTnet/<port=1119>/agent - CURL error: 0, Status Code: 404

HTTP 404 usually is no good, but libCurl usually indicates successes with 0, so I guess I’m confused what happened there. I do not believe my router is blocking port 1119.

  1. Most other logs seem to be okay, agent makes GET requests to various endpoints and most everything is a 200 series status code, but around line 7365 of the Agent log (again, talk to your tech support team) I see this entry repeated…a lot:

[I 2019-08-17 15:07:50.0878] Duplicate POST /install/destiny2 completed in 0.9680 ms
[I 2019-08-17 15:07:51.0297] Duplicate POST /install/destiny2 completed in 0.7520 ms
[I 2019-08-17 15:07:51.0347] Duplicate POST /install/destiny2 completed in 0.9080 ms

  1. Now here’s the extra interesting thing - I have been watching my network traffic via CTRL+SHIFT+ESC and sure enough…Blizzard update agent is making network traffic (and around ~63.4 Mbps worth - or 7 megabytes per second, which is an expected speed for my network connection).

  2. I opened C:\Program Files (x86)\Diablo III in explorer and sure enough…there are files. If I right click the folder, I see I currently have 9GB in this folder, and it’s steadily rising. In other words, I AM downloading the game. EDIT: As of this forum post, I’ve downloaded what I assume is the entire application.

  3. Your front end battlenet client DOES NOT indicate progress is being made. The application spun and spun…and then (I assume) hit a timeout and gave up. The front end did not consider Diablo II/Destiny 2 to be installed.

  4. I attempted to scan for games, and while the battle net client found the install folder, the front end once again either froze at a progress bar, or upon reboot, failed to connect to Blizzard Agent. Reinstalls of the Battle net client, even after removing cached files in %PROGRAMDATA%, %APPDATA% and %TEMP%, still would not resolve this behavior.

  5. After a night of allowing my computer to idle (without going into lock screen), I noticed that the Blizzard Agent has spawned 5 processes on my computer! I do not have the “Allow multiple instances of BattleDOTnet option” marked in my app configuration, so I guess I am surprised by this.

  6. I have provided exe checksums for Battle net and the Agent itself. I would do an integrity check of the actual client files, but I don’t really know how best to tackle that. As a side note: you guys may want to consider providing a service to validate the install.

PS C:\Users\bacon\Downloads> CertUtil -hashfile ‘C:\Program Files (x86)\BattleDOTnet\Battle.net.exe’ MD5
MD5 hash of C:\Program Files (x86)\BattleDOTnet\Battle.net.exe: 9a18538ee69086d39896c167df9bdd30
CertUtil: -hashfile command completed successfully.

PS C:\Users\bacon\Downloads> CertUtil -hashfile ‘C:\ProgramData\BattleDOTnet\Agent\Agent.exe’ MD5
MD5 hash of C:\ProgramData\BattleDOTnet\Agent\Agent.exe: c6fb32603dd120ed913c32ac1e11db48
CertUtil: -hashfile command completed successfully.

  1. I intend to respond to this forum post with things that I’ve already tried, as per your support forums, and the sheer amount of things that I actually have tried that have not worked leads me to strongly believe this is in fact a bug with the client. More to the point, I believe (only a guess) there is an issue with inter-process communication between Blizzard Agent and the Desktop App