D1 works fine but Hellfire STILL won't launch from desktop

As the title says, I got Diablo 1 to work just fine, but Hellfire won’t launch without an immediate crash.

After a ticket and only automated/copy paste responses that DIDNT EVEN READ I was having trouble with HELLFIRE and assumed Diablo 1 - sent me a broken link to get help from the community.

For Hellfire - I’ve tried in compatibility modes and from the desktop icon - screen just goes black and back to desktop for Hellfire but not for Diablo 1 - that game worked just fine. If there isn’t a fix from blizzard, im told GoG has the game for the same price and they took the small amount of time to get it to work BEFORE selling a dead product and i’ll have to refund the game from blizzard sadly to purchase it from a competitor

1 Like

Sounds like you need a cnc-ddraw wrapper

Already using one for Diablo 1 to work so i tried it with hellfire to no avail and got this ERR:

Exception code: C0000005 ACCESS_VIOLATION
Fault address: 09973B30 00:00000814

Registers:
EAX:09974531
EBX:09973B30
ECX:00000000
EDX:000001E0
ESI:09570000
EDI:0A72000C
CS:EIP:0023:09973B30
SS:ESP:002B:0019F878 EBP:0019F928
DS:002B ES:002B FS:0053 GS:002B
Flags:00210216

Call stack:
Address Frame Logical addr Module
09973B30 0019F928 0000:00000000

You placed the ddwrapper files in the Hellfire installation folder as well?

Yes I did, and it hasn’t seemed to work.

you might have to ask funkyfr3sh on github. I dont know what that crash code means

1 Like

Try running it using DevilutionX

1 Like

that was the fix that worked! and man, that port is badass! Even full screens and tabs out no problem!! thank you much!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.