Can't reinstall battle.net app

I first couldn’t get WoW Classic to update, it would just sit at initializing. I checked windows updates and any other pc updates. I restarted my PC and router, I even uninstalled the battle.net app. (after reading a list of what to do on this forum.)
Now I’m trying to reinstall it and it just sits at the little window saying: Starting Battle.net…
I’m at a loss.

Hey there,

Getting in a scan and repair loop followed by the reinstall not working can be frustrating. Usually that’s due to interfering programs, damaged files, or a connection problem. The following should address those common causes:

Nuking all Battle.net application files

  1. (Note you probably have this done already) Uninstall the application - https://battle.net/support/article/30304
  2. Press Windows key + R and type in %temp%
  3. Delete anything related to Blizzard or Battle.net
  4. Do the same for %programdata%, %localappdata%, %appdata%
  5. Reinstall the application! - https://battle.net/account/download/index.xml?show=bnetapp

If you have security software, try disabling it. AVG and Avast have been seen recently interfering with downloads and it may be a factor here, however other AV programs can also be a factor. Keep in mind this is temporary only and they should be reenabled after testing.

Lastly is to try another connection. If you have a friend or neighbor’s network to connect to, that can be used temporarily to test. You can also try a hotspot or tether with a mobile device if your plan and device supports it.

Thank you for the help, I did all the steps and had this happen:
Whoops! Looks like something broke. We’ll try to fix it, so please try again later.Error Code : BLZBNTAGT000008FC
I then followed the steps on it’s page:

  1. Restart your computer to resolve problems caused by programs and services running in the background.

  2. Update or temporarily uninstall any security programs, which may mistakenly identify the login module as a security threat.

  3. Uninstalling and reinstalling the Battle.net App may resolve rare launcher issues.

  4. [Reset the WMI Repository.]/article/000257703) This can help in cases where the root problem is caused by the WMI service failing.

After all this, it finally installed and was able to update the games. It’s now playable. Again thank you for the help.

1 Like

I have the same problem as Veevoque and have tried everything mentioned and its still not working, it gets 89% way through downloading the battlenet app then freezes.

Cannot reinstall battle.net/blizzard....for some reason the browser seems to stop it from downloading. I have been battling this for 2 days. Need a fix asap!

Call of Duty doesn’t work

I am having the same problem. I keep getting error code BLZBNTBNU00000006. Please help

2 Likes

BLZBNTBTS00000029 I have tried to updates and fresh install of Battle.net Apps but going nowhere and just getting the run around from the Blizzard support. It works just fine with Windows 7 or 10 but it will not work with MacOS whether it was working before or not but as of right now I need this to be fixed like yesterday. I just signed up and renewed my monthly membership but I can’t even play the game that I have paid for.

I first tried to download it using google chrome and it didn’t work. Then I used Microsoft Edge and it started downloading immediately.