Cant download battle net anymore

When I was doing an update for WoW I canceled it. When I was ready to play WoW again, my update didn’t continu, so I reinstalled Battle Net. After this I cant download Battle Net anymore and it keeps crashing on my macbook. I have no clue what to do since I been trying to download and remove it for over 30 mins. It only says ; Something went wrong with the downloading a required update. Please check your internet connection. As that is all fine, I dont know what to do. Hope you guys can help me.

Update:
After trying it for 15 mins more, I somehow download it. But still cant play WoW – Error code BLZ51914001

Hey, SuperPants! Thank you for updating the post about the issue. Glad to see that the Blizzard Application was able to be downloaded!

As for the BLZ51914001 error, this is typically a connection related issue, but these steps may help with the error.

If the problem continues, could you provide us with a pathping test? Let this run until it reaches 30 hops. Copy and paste the text file created and paste it between two ~~~ like so:

~~~
Pathping Here
~~~

If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for pastebin.com/123456)

I had the same issue. Tried for an hour until I found a mirror that wasn’t hosted by blizzard. Worked like a charm. Not allowed to include links so just google search:

downloads digitaltrends blizzard-battle-net mac

and you should find it just fine. Hope this helps.