Cannot update WoW TBC - don't have administrator rights

i got the same problem with both starcraft 2 and heroes of the storm i tryed everything mentionned and nothing changed i even tryed to unistall heroes of the storm and reinstall it but does not let me reinstall the game for the same reason as for the updates.

1 Like

No that did not help at all.

Same thing for me on Windows 10, I can’t launch HOTS

1 Like

I am also experiencing the administrator privileges and failure to update errors:
“Whoops! Looks like something broke. Give it another shot.​Error Code: BLZBNTAGT00000BB8”. Scan and Repair also fails with an error. This all started immediately after a app update.

i am getting the same error on MAC.

Uninstalled everything ( client, games, /shared folder , etc ). Then i reinstalled and worked for a day. Now i get everything all over again.

Checked disk, permissions, etc and i have admin… is there a solution on this?

Hurray i found a way to solve this.

so after reading : WOW Update BLZBNTAGT00000BB8 error - #4 by CupOfJoe-1687

i noticed that i did not think about the folder with all the replays , saves and everything (somewhere in “documents”). and in deed they did not have the administrator autorisation and i could not give it to them.

But i simply renamed the " name of the game" folder inside the " documents" folder and then i could do the update i needed and i went back to “documents” to see that a new folder had been created after that i just had to copy and paste all my saves and replays from the old folder into the new one.

and BOOM problem solved.


Tried to clear the classic/Logs folder, and that unlocked the situation for me. I managed to update the game and log into my realm for the first time in a few days.

That did not help at all.

thanks bro that helped me but with a similar problem in starcraft2 :ok_hand:

I had same problem but with HotS.
Someone on Reddit suggested to delete the Heroes of the Storm folders in My Documents. That worked for me.

This worked for me.

The security permissions on the Heroes of the Storm folder in Documents had been stripped. No user/user group had rights to delete/modify this folder.

Used my admin account to take ownership of the folder. This allowed me to change the permissions to allow administrators Full Control. Which allowed me to delete it.

Tried installing again and it worked. Thanks.


This worked for me as well. Big Sur - Intel iMac 2017.

Incredible… This works… I can’t understand how this company screw up something so stupid.

Thanks man

Tried again all the forced admin rights options, including “enclosed items” option, still bugged during update. It now mimiks a start, then fail after fectching 728/760 indices.

Note that I am playing the game from an external SSD, so it is not even an issue of local glitch, it is straight-up a bug from the bnet launcher. Also tried to completely delete bnet launcher and reinstall it, including everything related to Blizzard in my Shared folder. Still no fix.

We are closing on the SECOND WEEK of this bug. I wish I could treat my own clients as you treat yours, this is unbelievable.

the solution is ( la solucion es) / first step (primer paso) open the folder my documents or documents in windows (abre la carpeta mis documentos o documentos en windows ) second step (segundo paso) locate the folder named StarCraft II (localiza la carpeta llamada StarCraft II) and cut it to the windows desktop (y cortala al escritorio de windows) third step (tercer paso) rename star craft ii folder on windows desktop as sc2 (renombra la carpeta star craft ii en el escritorio de windows como sc2) final step (paso final)
open battle net and repair starcraft, if you uninstalled the game reinstall starcraft and play again (abre battle net and repara starcraft, si desinstalaste el juego reinstala starcraft y vuelve a jugar)

This worked for me

Go into your Documents\Starcraft II folder and change Owner of the folder…

Right Click folder Starcraft II>Security>Advanced>Owner: Change>Advanced>Find Now> Pick your Computer/User Name…

This folder is inside MyDocuments not inside the Program Folder

I’ve been down for a week with this issue with WOW retail on a MAC running OS 11.6.1. Tried most of the fix suggestions in this thread but nothing was working.

Finally bit the bullet, and did the delete and reinstall of the game today, fixed the problem and everything is working fine.

I’ve tried deleting every game and bnet, reinstalling, repairing folders, any workarounds on the five threads I’ve seen. I gave up and unsubbed from WoW and I can’t even play Overwatch. Even when I reinstall it just starts “scanning” games again, as if the files for the games I’ve uninstalled even exist! Awesome.

thank you this fixed the problem, would give you more upvotes if possible :slight_smile: the client wouldn’t let me update starcraft 2 either, I deleted it then it wouldn’t let me re-install it either, this problem is not limited to wow tbc


We need to be compensated for the Battle.Net error that prevented us from playing the game - Community / General Discussion - World of Warcraft Forums (