Cannot download WoW on Mac Ventura

WoW was working fine yesterday after downloading the pre-Dragonflight update. I ran a couple characters through the elementalist boss fights to grind currency for the new gear and logged off. Tried logging in today (17 Nov 2022) and the game required another update. Got the Oops Something Broke alert (BLZBNTAGT00000BB8), clicked through and followed the listed steps.
Scan and Repair on the battle.net app got stuck in a loop and kept giving me that same error message, so I uninstalled and reinstalled battle.net app. That download went fine, but upon opening, logging in, and once again attempting to update WoW, a new error (BLZBNTAGT00000840) popped up. Followed the listed fix it steps again. Repair tool pops an error. Battle.net app is a fresh install. So I uninstalled the game, quit the app, restarted my computer, and tried to reinstall WoW via the app. No dice. Same …840 error. Uninstalled everything again, restarted, did a second fresh reinstall of battle.net app (it worked) and once again attempted to install WoW. Same error. Again, this game was running smoothly 14 hours ago! No settings have been changed, no changes to software, firmware, or hardware whatsoever. But now it won’t even install. I’m out of ideas and frustrated.

2 Likes

Same issue here unfortunately… I knew I shouldn’t of updated to Ventura lol.

Same here. Tried running an update this afternoon and it’s stuck at 58% with a BLZBNTAGT00000840 error. Ran “Scan and Repair” with no success. Running Ventura 13.0 on 2020 M1 MacBook Pro. Did have an odd thing happening where WoW kept asking to have access to the system microphone earlier today, prior to the update attempt. Will keep trying to figure it out on my end…

On Ventura (Intel) (Poss. ARM too) - go to System Settings → Privacy & Security → App Management and permit “Agent” to update your Installation. Without this setting, you end up BLZBNTAGT00000840’ing.

3 Likes

Thank you Acid! That seems to have done the trick. Now I really do wonder if it was related to the mic access popups I was getting earlier. How odd. Thanks again for the cure!

1 Like

Hi, I’m experiencing the same issue with the BLZBNTAGT00000840 error. Attempting scan and repair gives the BLZBNTAGT00000BB8 error. I have temporarily disabled security software and have already used the solution posted by AcidCystor – doesn’t seem to help on my machine running Ventura. Any other ideas or workarounds?

I’m seeing the same error after applying the solution. Download gets to between 5-10% and fails. Any other suggestions?