Can´t seem to get the Desktop app installed!


#1

I´m so frustrated!

Over a week i´ve been trying to ge t this Desktop app installed so i can play Classic WoW. But literally nothing works. It just says updating Blizzard agent, or goes through that phase and installs to 50/60 percent and then just restarts from 1%.

I have literally tried so much : Disabling firewalls, checked for VPN. Fumbled with Secondary logon service to changing my LAN settings. Restarting and deleting files.

Please help blizzard or anyone else!


split this topic #2

A post was merged into an existing topic: Can’t install the Blizzard App after “uninstalling” it


#3

Hi YuriB,
I had a similiar problem. Mine got stuck at about 30% and it said “Updating Blizzard Agent”. You can try deinstalling Battle net deleting all Battle net related folders. If you hit “Windows+R” you can find every folder, some are in “%localappdata%” or in “%programdata%” or in your “programs(x86)” on the local disk. Then you can try deactivating Antivirus and/or Firewall (you obviously already tried).
Nothing of that worked for me and i was really frustrated since other people seem to have success with these methods. But then i found a method that worked. I connected my PC to another network and it finally finished the installation (Just to mention: the none working connection was sattelite internet and the working one was a dsl connection).

Hope this can help.

Best regards
Venom