Bought Warcraft 3 reforged cannot download

I bought Warcraft 3 reforged Spoils of War yesterday. Yet I cannot download the game. The download button on is stuck on “Buy”. I checked my account and it says i bought the game. I uninstalled and turned my computer off it didn’t change anything.
I asked the support but haven’t had an answer yet.

It can take a up to 72 hours before the order is complete – it normally doesn’t, but…

What is the status of the purchase ? Does it say “Complete” ? If not, refer to this Support article for the meaning of your order status:

That was the right thing to do… purchasing issues cannot be resolved on the forums; you need to contact Blizzard Support directly with a ticket.

1 Like

Thanks for the answer. The status says complete but the payment wasn’t delivered by my bank yet. I guess i have to wait a couple of days to find out if it proceeds.

Hey there WolrdWarZero,

I checked the order for Warcraft III and do see it’s showing complete with no problems. My guess is the application is having some problems with seeing that you own the game. There is a workaround that usually works to get it installed so you can play.

This can be worked around by starting the application but not going online. If already logged in, click the Blizzard logo in the upper left side and select Log Out. When at the login screen, you’ll see a gear wheel above the email field. Click that and select “Continue Without Logging In”. Then select Warcraft III and start the install. Once it’s installed, you’ll want to click the logo in the top left side again and select “Log Out”. This will bring you to the prompt to log in normally. At this point you’ll want to do that and test if the game will launch.

1 Like

Awesome :star_struck: everything worked out great ! Thank you a lot !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.