Blizzard Authenticator bug: "An unexpected error occured"

Hello there, i opened a ticket for this error and i was refered to create a thread here here by the Tech Specialist Game Masters. I will copy/paste some of the stuff i posted and replied to my ticket down bellow, hoping for a fix or suggestion on how to make the authenticator work on my new phone.

I changed a mobile phone, installed the blizzard authenticator but right after the login i get an error message: “An unexpected error occurred. Please try again later.” I tried everything the blizzard troubleshooter said before contacting. My mobile is Redmi Note 9 Pro with the latest MIUI 11.0.6.0. I searched the web and there are people that are experiencing the same problem as i do as well on the forums as well but there are no answers.
I don’t have an AdBlocker, Android VPN is disabled and i don’t have a VPN app, i did all the troubleshooter steps and the language on my phone is set on English (US).
To save you the trouble on finding what steps the troubleshooter suggests to do and if i actually did them, i reinstalled the app, i restarted my phone, i cleared cache/storage, i gave storage permissions to the app, i tried setting up the authenticator on WiFi and i tried on Mobile Data.
Sometimes after the login i actually saw for half a second or so the serial/restore codes before getting the error. I just want to get rid of my old phone that i am stuck with right now so i can authenticate my logins on battlenet services.
Thank you for your time.

2 Likes

i’m having the exact same issue! on the one hand i’m glad i’m not alone, on the other this sucks a lot. not sure what to do from here except hope i don’t need it?

1 Like

Yeah it does PartyPants…
Well, you’re going to need it at some point. The authentication you gave doesn’t last forever afaik.
Lets hope we get a useful answer here.

P.S. @Zenlaka that moved my thread from desktop app tech support to mobile bug report, i know i posted it there but it was the destination of the link the GMs gave me (https://us.forums.blizzard.com/en/blizzard/c/desktop-app-tech-support/7) so i made it there.

More specifically Authenticator Mobile Bug report. Don’t worry about it getting moved. It means that Tech Support can’t fix this with current options and instructions. It needs to be investigated by QA and resolved - or work around instructions given to Tech Support so they can share them with players.

For now, keep your old Serial Number/Restore code handy and keep the old device. I don’t think it has to be paid cell service. If it can turn on and access the app it should still work. Once they sort out the bug you can install YOUR Auth on any compatible device by entering the serial # and Restore code.

Maybe a tablet or something would be preferable? You can have it on as many devices at one time as you want.

P.S. Excellent write up and details including all your troubleshooting. That is helpful for QA.

I THINK you can use SMS Protect (the text messaging service) to remove an Authenticator from the account yourself. Not ideal of course because then you don’t have the Auth! If you have another compatible device consider using that for the time being. I am still using my old physical one!

Hello. Reporting same issue. iPhone XS Max. Trying to clone my authenticator onto another device. I actually went in, detached the current authenticator, and generated a new one, and even still, can’t transfer the code to another device. I am able to log in with push notifications as well as generating the TOTP code, but I cannot take the serial number and restore code and manually enter them into a spare android phone, just as a second copy of my authenticator. Some kind of bug with their app or their system.

Same problem here, the exact error message it gives me is:

Error…

An error occurred while restoring your authenticator. Make sure the serial and restore code are correct, then try again.

They are both correct, as I just confirmed on my old phone, where the Authenticator is working just fine. The new one is a Pixel 4a if that matters. I get the error both when trying to use a restore code directly, and when trying to log in using email and password, which sends me to the same restore code page.

I am watching this thread as I also have the same problem. I have a working active Authenticator on iPhone XS Max, trying to just clone to a spare android phone with current Google Play store version. The codes as well as the SMS protect functionality both fail when trying to restore. Same error message as post above me.

My impression is there is a bug on the backend that interprets the input from these requests. I submitted a ticket and even provided the screenshot showing my restore code information. I would like to have their staff manually input the codes into the apps locally and show that it does/doesn’t work

Has anyone removed the authenticator from their account and then started the process over on the new device?

Even if they did that, the serial number and restore code should work to re-install the same Auth on their device. Once done, they would have to go through the linking process again.

They can have the Auth on many devices at once and it should not cause issues.

I just don’t want any unprotected accounts out there!

Me either. I’m not encouraging anyone to do these steps now, just asking if they have been done already for bug tracking.

Getting that information could narrow down where the bug is specifically happening; whether it’s with restore codes/internal system only, or if it’s based on devices/security protocols on those devices.


Edit: I know the OP already opened a ticket, but please do so if you haven’t already. The more tickets they get about this issue, the easier it is for Blizzard to track down the cause and help people. Here’s the link: https://us.battle.net/support/en/help/product/services/316/322/solution

Hi there,

I was having the same issue on my new device (Samsung s20) what I was assuming is some sort of bug preventing the authenticator to switch between devices and I decided to give a try to this solution even at the risk of being unprotected for a wile until the issue gets fixed.
I can confirm that in my case login in to my blizzard account, disabling the authenticator and setting up auth app fresh just worked fine.

1 Like

I can in fact confirm that this worked!
Using the sms protection for the authentications needed, i detached the authenticator from my account on blizzard.com, started the setup process on my blizzard authentication app and everything worked as intended :star_struck:!
Thank you sirPapaya :slight_smile:.

Please don’t close this thread. Detaching an active Authenticator via the blizzard account dashboard works. I don’t want to do that. I want to use my existing serial number and restore code to clone my Authenticator onto another device, to have a backup. IT WILL NOT WORK. Any support staff can get in contact with me and I will screencap my Authenticator showing the serial and restore code, and invite them to attempt to manually restore onto a native app.

3 Likes

I talked to my MVP contact in Customer Support about this last night. He is not part of QA or any sort of developer team though. It has been escalated to get those who are responsible for the Auth app to take a look. Not sure when/if you will hear anything directly. I also don’t expect much traction on a weekend.

I would not give up hope though. They really want accounts to be secure.

1 Like

I have a similar issue - mainly that the 2nd phone I try to attach fails. If I wipe the authenticator from the account and set it up anew - it works on the first device I configure it on.

If I take the restore code to a 2nd device, (or even use the login) it spins and then fails immediately with the “unexpected error occurred” [even happened on a fresh phone] If i wipe and set it up on the 2nd device first, it works, but then taking the restore code to the 2nd device fails just as the first one had.

Yes dude, same, same. Even attempting the SMS protect based restore on the second phone fails? It “acts” like it’s going to work, then errors out and goes back to the login screen?

TL;DR: The issue was “resolved” by removing the authenticator and then adding the new one from the new phone.

I contacted their support, and the answer was that “the authenticator […] is phone specific” and “There is no way to just swap the authenticator from phone to phone”. They said that SMS protect is phone independent, as it’s coupled to the phone number, but using SMS as a verification method is not an option for me, because it’s basically just a digital post card.

So in conclusion there does not seem to be a way around removing the old authenticator from the account settings, and then adding the new one; a support article (can’t add links here, google for “blizzard authenticator switch phones”, first result) states as much.

Here’s to hoping they add an option to just use any common TOTP app in the future :slight_smile:

You guys are lucky… at least you got your old phone still working.

I had my phone die last week, it’s currently in repair but it might not be fixed at all, But I had the Serial & Recovery Code saved up as a screenshot so I should be fine.

yet, trying to add authenticator on a 2nd mobile now so I can login to my account does not work, and I don’t even have access to my old mobile right now to remove the authenticator and add it to my 2nd mobile.

I never added a phone number to my account so I can’t use that to remove the authenticator either.

I got a solution.

#1 Open accountDOTblizzardDOTcom/security
#2 Disable fully authenticator app at the correct section.
#3 Open auth. app on the new phone.
#4 Register it on the new phone
#5 Ur done.

It worked for me, i hope i could help.

If this is now true that is a MAJOR change. A core function of the Authenticator app is that it can be put on multiple devices and moved from phone to phone by using the Serial Number and Restore code. That is the whole point of the Restore function in the Auth app!