"Blizzard Agent went to sleep, attempting to wake it up"

Constantly stuck at this screen when I’m trying to log in.
Eventually it resolves, but often I’m kept waiting for 5-10 minutes until it FINALLY clears up and lets me launch a game (which I cannot do even if I launch the .exe directly from the folder).

This has only started happening since the update to the Blizz launcher last week (or 2 weeks ago? Can’t remember).


same to me. since last crash that everyone complain app sleep, then it would always take like 20s sleep before truely login, and app always says: updating battle.net.
dont know if Blizzard fix this or not, maybe some bug still stuck.

Hey, Saer and Doudou! This is a fairly common error to occur when there’s issues with loading the agent. It can be caused by a corrupted update or files, security, or windows level issues such as WMI. There’s a few suggestions to resolve this issue.

  • Troubleshoot security applications.
  • Uninstall and reinstall the Blizzard Application.
  • Reset the WMI Repository.
  • Reset the Windows Firewall. Alternatively, you can add the Blizzard Application through the Windows firewall.
  • Disable Windows Fast Boot.
    1. Press Windows+R
    2. Type powercfg.cpl into the Run prompt, then press Enter
    3. Select Choose what the power buttons do on the left side panel.
    4. Click on Change settings that are currently unavailable
    5. Uncheck Turn on fast startup (recommended)
    6. Click on Save Changes
  • Try a New Admin account. This resets a ton for the user profile and recommended even when there is already an admin account.

If the problem persists, does an alternative connection work? If so, let’s gather a connection test to our authentication servers. Run this test while the “agent is asleep” error occurs for 5-10 minutes. Use the IP/Host name: us.actual.battle.net

1 Like

Guys I solved with this !!!

Press Windows+Q and type cmd into the search bar that pops up.
Right-click on Command Prompt and select Run as Administrator
Type net stop winmgmt into the command prompt and press enter.
When prompted if you wish to continue, type Y and press enter.
Type winmgmt /resetrepository into the command prompt and press enter.
Restart your computer to pick up the changes


Let me know if worked. After I noticed a error code and I found it was maybe a WMI Repository. So I solved with this. Actually also I used AdvCleaner to scan from u know, Ads bull***t and trojan.
Try do that too.

1 Like

It’s 2022 and we still have this issue!! Please tell your team that is in charge of this TO GET THEIR ACT TOGETHER AND FIX THIS!! I PAID MONEY FOR THESE GAMES AND NOW I CAN’T PLAY THEM WITHOUT REINSTALLING THE CLIENT EVERYTIME THERE’S A FREAKING UPDATE!! Right now this is THE WORST gaming client out there!! If you can’t fix this, THEN MOVE YOUR GAMES BACK TO STEAM!!!


Support staff have no hand in the development of the client. That said, the program going to sleep is a decision your operating system is making, not the Bnet app.

Please refrain from necrobumping threads from over a year ago.


I just want to shed some light here - and I’m not defending the necrobumping of the old thread and apologize for also posting within, but I want to clarify something important.

The message regarding the Blizzard Agent going to sleep is not actually an indication of a local issue with the service / client, the message is produced when there is issues communicating with the Battle.net servers. Which admittedly, primarily would be caused by the users local environment / firewall. It’s just inaccurate to state that the message is being generated because the users operating system made the call to put the agent to sleep, as this is not usually the case (though, in some edge cases the error can indeed be generated by the agent failing to load).

Given that multiple people (including myself) with different providers and setups all started experiencing this issue within the last week would tell me that more likely some sort of route change or issue with response times that is impacting a subset of users, which I think is why we’re seeing a few posts / bumps for old threads regarding this error / message.


I have been a paying member of the Wow community since 2004, I haven’t posted anything until now. When I saw the necrobumping comment as a rude gesture towards a paying customer, I just had to respond.

I would like to say that I work in IT and we deal with similar clients/launchers and this is clearly not a system level issue. If that were the case most launchers would have similar issues. Everything within my system is fine, ALL other games run PERFECTLY. The only app I have an issue with is Battle.net. The game was running fine for a month or so then stopped and stuck downloading with the error that the Updater has gone to sleep and for whatever reason it will fix itself if you wait long enough, without doing anything. Things that make you go hmmm…

If necrobumping means mentioning an issue that is still occurring and plaguing paying subscribers well into 2022, and I hope it does, because that is what is actually happening. Here is an idea, if you don’t want people to post on what is wrong, then fix it or find a new developer for the client. Again, all other games work perfect. I’m happy to give them my money instead.


The network settings/connections are managed by the operating system.

A routing problem is currently occurring for New Zealand residents reaching the Sydney server, but it just started last night.

I don’t work at Blizzard. Asking someone not to necrobump isn’t rude, those are the fourm rules.

If I had a nickel…

Aggressive commentary and threats of quitting aside, the majority of solved cases I found across their game forums point to operating system issues, like those outlined in their support documentation.

Please use the ticket system to further investigate the issue with the staff.

Can you pls get DEV to add the freaking game objective as a tip BEFORE I get a LAWYER to GET YA’ll to do it along with Offerings of Refunds to ANYONE that has bought THIS game in the past 6 years and not logged in for over a MONTH!!! REDICULOUS BLIZZARD!!!

Are you suggesting that suddenly, a multitude of us have all coordinated to change our local environments, modifying our gateway and switch configurations and adjusted our windows firewall rules to make this issue crop up?

Quite frankly I find your attitude here to be very dismissive and aggressive and not in line with the typical responses received. While I understand you are not employed by Blizzard you do carry the MVP role and as such the expectation is that you would interact in a positive way with the community.

I’ve worked in IT for 25 years, I manage large corporate networks and have analyzed more packets than I could possibly convey. And yes, I saw your response to the previous poster stating that they work in IT with “If I had a nickel…” but the point of these clarifications are to show that the people coming forward have experience in the area, as it’s understood that most problems are indeed the fault of the users environment / provider.

The issue isn’t impacting to the point of unplayability as it does eventually establish the connection, it’s just an inconvenience and seeing as this is the “Desktop App Tech Support” forum I cannot think of a better place for people to voice their concerns about issues with said application and seek technical support.

I’ll stop posting here, but you should probably re-evaluate how you’re interacting with the community - and I mean this in the most sincere and non aggressive way.

Thank you all for the help.


Considering a Windows update just rolled out over the last 5 days, it does seem incredibly possible.

Blizzard reps have a very RP-centric approach to their responses; mine are straightforward (and I sometimes call out hyperbole). This is just how my brain works. The way I respond is the same as before joining the MVP program, and ya, it doesn’t work for everyone. Some enjoy the brevity while others will find fault and give unsolicited advice on my next interaction. I simply can’t please everyone, but my success rate is about the same as the staff’s in the end (considering the ire they receive across all forums).

I hope the staff is able to help via the ticket system and you all find a resolution to your issue.

1 Like

Unfortunately there is no fix for this. But a work around is to just run the WowClassic.exe and bypass the STUPID battle.net agent. Mine takes 10-20 minutes to wake up. And blaming it on windows when everything else works fine on this computer is silly. And why does it take 10-20 minutes to wake?


Hey, I went nuts trying to figure this out, then restarted my router on a whim and everything fired right up. Good luck and I hope this helps!

You need to clamp to pmtu. Only on battlenet happen this thing with mtu and mss,

Nicole, I appreciate the modestly civil nature of your response. There is one issue tho, your blatant underestimation of “regular users” IT knowledge just makes you come out as very condescending. You might think this is impossible, but maybe, just maybe, you are actually wrong in this case, never had issues on this system, haven’t updated it for a while (just shelfed it out after a hiatus), the new app just doesn’t want to work consistently.

Sorry if this is hard for you to grasp, but non OS issues also crop up every once in a while, and plague users that had constant play without any issues. Please actually look into the issue instead of just shelling the cliché IT response of something in the lines of “just try turning it off and on again”.

Civility ending here, this just reveals your incredible lax nature in solving issues, sure you are not part of the dev team or the tech support higher ups (and if you are, I dread for the future of this company), but that does not give you the right to shrug off issues you don’t experience but other users do.



11 posts were merged into an existing topic: [Main Thread] Agent Went To Sleep BLZBNTBNA00000005