won't open at all

Battlenet refuses to open, it gives unexpected error with this ID 1403DAA8-0BD8-4D05-B30E-9A66FBFA27BA
Tried already: clear cache, clear appdata and programdata, uninstall and reinstall, logon service, selective start up and few more stuff.

Reporting the same issue here

Ok i solved it. It was a compatibility issue with AMD Radeon Software, version 19.9.2.
I had to turn off all “fancy” stuff in the gaming section and now it works

1 Like

Thanks for your report! We’re seeing a few issues with 19.12.2 drivers at the moment. Just to make sure, is this the driver you were having issues with? We’ve found that rolling back to 19.12.1 has helped a few users so far.

Out of curiosity, what settings were adjusted? A few reports we’ve seen have been with Radeon Chill, Anti-Lag, Enhance Sync.

Yeah its 19.12.2 i just had to add as a game and turn off amd link and a few other features.
Just uncheck all features under gaming features


A post was split to a new topic: Tchernobog - Won’t Open

Hey thanks this worked for me. All I did was open the software, “Reset to defaults”

This topic was automatically closed after 54 days. New replies are no longer allowed.