BattleNet won't launch CoD WZ2

Hello y’all.

Last Tuesday I had to wipe my entire computer to zero. Re-installed windows, and of course, everything else.
Now I’m encountering a new problem with CoD MW2: It won’t launch. This issue already happened to me once, but I fixed it by changing the location of the game. Now this method won’t fix it.

I tried everything I could find on the internet, really, here is the list:
Updated windows and GPU drivers.
Re-installed CoD and BattleNet
Antivirus and Firewall disabled.
Give admin privilege to the game and the app.
Changed the location of the game.
Turn off Discord and Nvidia overlays.
Assure Overclocking is off.
Rollback nvidia drivers.
Turn off every background process that wasn’t necessary.
Changed the language of the game.
Changed the servers from americas to europe.
Assure that VPN is off.
Tried to log in with a different Internet Network.

Fun fact, WZ 1 works.

At the beggining, the error was that the game stucked at the Loading screen. Now if I press Play it changes to PLAYING NOW and back to PLAY. At the second time I press PLAY y appears this error:

An error has occurred while launching the game. Follow the steps in this support article to fis the issue.

And the article is about giving admin privileges to the game.

Is there any solution or I need to quit the game? Thanks.


if you get any answer to this, please let me know I have the exact same issues.

1 Like

i even tried going to steam and had the same problem i believe its a activision issue, ive done everything you have except changing region and language… im beyond frustrated…i thought my acct was hacked or banned and no issues…and still no response from support there either

Was there a repair to this> I reinstalled my windows too and now I am unable to load MW2. I could load COD MW1 and Blacks ops just fine (just to check) but MW2 just gets stuck on the loading page. I can’t even close it. I have to restart my computer every single time.