Whoops something went wrong

Downloaded client for Windows
Every time I attempt to login it appears to load and then I get a message “Whoops! Something went wrong. Please wait a moment and try again”

I’ve tried loads of times now on different days and still no luck.

I’ve tried uninstalling and reinstalling. I tried deleting the Blizzard Entertainment folder (as found on another thread) and none of these work
This means I can’t download or play any games at the moment

Please help

1 Like

The message you are seeing is a generic message. Typically there is a code with that message. Get that code. Check the forums for any recently active posts with that error code and try any provided troubleshooting steps in that thread. If it does not work add your post to that thread. If there is no currently active thread matching that error code, reply back to this thread with that code so the community can begin assisting with troubleshooting.

Try changing your password. I was having the same issue today and that worked for me. It may be that Blizzard detected your password has been leaked somewhere.

1 Like

That worked, thank you so much

Turns out I’ve not used Battlenet for a loooong time. I logged in on the site, went to change password and it asked me for other information and then said I needed to change my password

If the app had said that it would have saved a heap of trouble and me posting here!

Thanks for the reply though, massively appreciated :slight_smile:

In my case it turned out that I needed to provide my date of birth in the account settings. This is obvious when you log in through the web, but the app gives no indication of what to do … it just provides a this error message and “reload” button.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.