Battle.net stuck on login

My battle.net app is stuck on the login process and won’t move on.
If I select continue without login, it loads fine without authentication.

This problem started on Wednesday after Blizzards updates.

If I then go to any installed game it displays We couldn’t load that

A message blinked quickly, the one below:

<html xmlns="http://www.w3.org/1999/xhtml"><head></head><body</body></html>

I have tried many solutions, and nothing has worked

  • Repair Microsoft Edge
  • Release IP and flush DNS
  • restart modem
  • remove Edge extensions
  • reset my Firewall
  • no anti virus running just defender
  • contacted technical support, got a generic reply that doesn’t help.
  • Delete battle.net directory from … | ProgramData
  • uninstall battle.net, remove as many regedit entries as possible
  • Reinstall batlenet
  • many other smaller solutions that have not worked.

Before you reply, please read what I have tried to save time. :slight_smile:

Can someone please help with this ?

»» UPDATE ««
Just found out that Windows 10 computers in the same house works fine with Battle.net app.

One Computer got a CLEAN Windows 11 installation with all updates, then installed battle.net and the same login issues happened. same HTML empty tag response.

This has to be something Blizzard have done from recent updates as all other game launchers similar to steam work fine (and always have).

1 Like

Always search the forum first, there are other solutions from previous posts as well.

Have the same problem!
i think the servers are down again…

I’ve tried getting on all day and all it says for me is that ’ Unable to connect to Battle.net.’
Even tho I’m connected… Something isn’t working right!

1 Like

I tried chrome and Brave and set as default with no luck. Tried repair of edge with no luck.

Unfortunately, I cannot get around this issue, and why would it happen on a Wednesday straight after Blizzard updates ? Coincidence ?

1 Like

It does not seem to be a widespread issue, as there are only a handful of posts. I’ve been able to login to Battlenet on my ISP and via VPN to the other coast. Where are you connecting from? There may be a routing issue.

We’re with Telstra NBN and there is more than one computer connected to the net playing wow and the others do not have a problem. So it is not a routing issue.

As mentioned above, IP released/renewed dns flushed etc…

firewall reset to default edge repaired… I cannot find a way to completely remove edge and re-install, if I could find a way this might renew the who9le browser issue.

I am curious though as to why out of all the programs i use like steam / xbos (no not loaded all at once) Battle.net is the only issue ?

1 Like

You didn’t include that info in the original post. If other computers are able to connect and one PC cannot, then it would be other software or security settings on that PC causing a block. As for what that is, no idea. Sometimes you can spot it in the export of an MSInfo, sometimes it’s in the export of the DxDiag if you’re lucky.

I’ve got exactly the same problem.

Raised a support ticket with Blizzard “support” 3 days ago (US97283609) and have yet to receive a reply from a human. Just an automated response with nothing helpful in it. I worked through all of the proposed fixes which did nothing.

  • Rebooted PC
  • Rebooted router
  • Reset account password
  • Removed authenticator from account
  • Cleared battle.net client cache
  • Downloaded and reinstalled clean copy of battle.net client

As it just so happens, I’d purchased a brand-new custom gaming rig which arrived today. Performed full install, and lo and behold - same error again. I can get into battle.net in offline mode, which will let me at least launch a game, however I then have to authenticate for that game manually. Cannot use chat or groups in the battle.net client. Nothing else on the LAN has gone wrong except battle.net.

I’ve installed the client on a separate gaming laptop, and it’s doing exactly the same thing. I can log into the website and the mobile app fine with zero issues. I’ve connected the laptop to a hotspot so it’s off the network that my new PC is using, still getting exactly the same problem with the wheel in the top right-hand corner just spinning useless telling me it’s trying to login.

(I’ve tried the different browser thing - no difference).

1 Like

having the same issue and have also tried all of those fixes… in fact I did it months ago and gave up… just tried again today and no luck… it’s quite frustrating

Ok I finally found a way to solve this, and I’m annoyed that Blizzard refused to take responsibility or investigate attachments I lodged.

Since battle.net updates with Social media connectivity and changes to login options some of the online connection settings may have corrupted or lost their authentication details, hence a blank html response.

Here’s what I did to resolve the issue:

  1. From Browser go to your battle.net account
  2. Click on Connections
  3. Remove all social media connections.
  4. Re-instate connections you want to use. In particular a secure 2=step auth Google account. Authenticate and accept the Google connection.
  5. Completely quit battle.net app from memory.
  6. Start Battle.net app and this time select the Google connection on the bottom.

By now, you should have a working App that will autoload from now on.

If this process has help fix your issue please let me know.

3 Likes

Great work on finding a fix! I’m now logged in and my game is updating as I’ve had to re-establish which drive my game is located on. Haven’t played yet, but so far so good. Thank you!

1 Like

Thank you, was thinking that my route had problems, this fixed it.

1 Like

Great work keeping at it until resolved. I’ve never once had any social media linked to my Battle.net account, so unfortunately this isn’t going to help me :frowning: I was using Blizzard’s authenticator but removed it as part of troubleshooting when this problem started a week ago.
So far the only two replies I’ve had in 4 days from Blizz have been one standard automated reply, then a standard human response from someone who clearly didn’t read any of the information I’d posted, asking me to do everything I’d already said I’ve done.

Try to add a Google connection to the steps above and see whether the app accepts it. Sometimes a redirection forces a change. :slight_smile:

However, make sure you have 2-step authentication on the Google account.

I tried linking to my Steam account but it made no difference. In the end I started working back through all the security settings I run on my Windows machines (I work in security, so am fairly paranoid about this stuff), and it turns out the battle.net client requires insecure/weak/exploitable protocols and/or cipher suites enabled to function (lol).

I re-enabled all the legacy garbage on the Win11 machine I’ve started using, and battle.net started working again (facepalm). Now to work through the list and slowly disable all the old stuff until I find the one that broke battle.net … sigh.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.