Battle.net not launching

My game froze and crashed mid-game while playing Black Ops Cold War and i suspected it was because my internet went out for a second, but the game would not close so i had to log off my user from Windows and log back in
After doing so Battle.net would not launch, and is not responding whatsoever even when I try to uninstall it. I’ve tried almost everything including deleting the cache folder, tried re-downloading the launcher from the website, and tried to start a game from the launch icon.

Is anyone else having this issue and has anyone found a fix?

Im having the same issue i think… Is it when you click play on coldwar and it just doesnt pop up but it stays running in the background?

Since the last update I have been having the same. Warzone and Cold War will not open, it says ‘launching’ and then ‘playing now’ but the game window doesn’t open. If you go into task manager you can see the game open but not showing in a window. I’ve uninstalled/re-installed the game and battle.net, changed the startup programs, deleted some apps like discord etc which could affect it and still nothing!! Very frustrating as I now have a game I can’t play!! If someone has any work arounds it would be great but seems to have happened since the last game update.

same problem here. Having launch issues with SC2 as well

If you find a way to fix it share it

I am also having an issue logging in! I cant play Cold War because for some reason Battle Net wont connect to online!