Battlenet not functioning properly, lost "play" button

In desperate need

My battlenet launcher will open, but it shows a huge wall of text rather than other graphics. In addition, my play button for every game has now vanished

Ive tried all the support recommendations, and nothing has worked. I did an uninstall and fresh install and that did not fix it. I cant even start my games via the .exe file.


I also had the wall of text for a few days, but today, not even a play button. Hope this is addressed quickly!

I am having the same issue as well. Complete blank wall. Restarted computer. Uninstalled folder and reinstalled, still blank. Also shut down my A/V software and checked my firewall settings, all show normal.


fico com raiva que a blizzard nao da uma resposta pros seus clientes, ja se passou horas e nada. espero que eles respondam logo porque estou na mesma situação. caso alguem de voces conseguirem avisem aqui porfavor.

I am having the same issue today, as described in all previous posts above.

Sometimes the Launcher has an advertisement on it that covers the Play button. Look for the X in the top right to close the Ad and then play the game you want.

1 Like

Thanks for that suggestion. It didn’t work, but it gave me something to do for a few minutes. I had high hopes.

Drat. I had a COD add or something that covered my whole launcher yesterday. I was hoping it was that easy.

1 Like