installer not working

When loading up i couldn’t get past the “updating battle net” or “updating battle net launcher” app so I uninstalled to then reinstall it. I’ve also deleted any of the files of my computer before I did the reinstallation. Now when i try to install I get stuck at 3 different places, either I get stuck at “updating battle net update launcher” or “updating battle net” or I manage to get past that to choose the download path but then when the installation starts, it stays at zero. I’ve restarted my PC, restarted my connection, idk what to do.


same issue for me stuck on update agent. tried everything ive read so far. if its not sorted in 24hrs i want a refund for dragonflight


same here. stuck on update agent. tried everything ive read so far.

Same problem here, can’t log in, tried almost every possible “FIX”

1 Like

je n’arrive pas a me connecter bien que j’ai réparé plusieurs fois !! aucune aide sur les forum , comment faire ?

I have been stuck trying to download the update for a few hours…so I finally decided to uninstall app and reinstall it…that was a mistake…now the app is stuck on installing…now sits at 79% with no progress JUST to reinstall the launcher app…after over a decade of updates, you’d think Blizzard could get it right…

Tô com mesmo problema

Nvidia released a new driver update today. Once I downloaded that, the game immediately started downloading.

1 Like

Same issue for me keeps getting stuck then saying something broke try restarting restart does the same thing.