Battle.net Desktop App not Starting but shows in Windows 10 Taskbar

Good morning all.
I have not used my laptop to play WoW in a while but, in getting ready for a trip I tried to update the game.

Oddly, when I try to open battlenet I am presented with the usual login screen, enter my info and get the notification to approve the login request on my phone. I approve it and battlenet seems to log in but the battlenet window does not appear. I can see the battlenet icon in the taskbar and can right-click on it but the only option that does anything is settings which opens the settings window as usual. If I click on any other options like store, games etc. nothing happens.

If I try to launch WoW directly I get the login window but then nothing.

I have tried deleting the battlenet files in Program Data, running as admin, and deleting/reinstalling battlenet.

Any ideas?

Uninstall the launcher and reinstall.

Hey, Errol! Hopefully, Darkfizzix’s suggestion did help! I am curious to what laptop model you’re experiencing these issues on. There have been a few certain models with Lenovo and Acer to experience issues with the Blizzard Application being invisible.

This is typically caused by outdated graphics drivers, which updating directly from the manufacturer’s website should help. ( Nvidia | Intel | AMD )

Could you gather a DxDiag file? Copy and paste the text file created and paste it between two ~~~ like so:

~~~
DxDiag Here
~~~