Battle.net desktop app installation issues BLZBNTAGT000008FC

So yesterday I decided to download Heroes of the Storm again, but my Battle.net was stuck at calculating space and then going blank with installation window, so I thought of doing a reinstallation of a Battle.net desktop app and it only went downwards from then onward.

Uninstalling was completed easily. Then, when I tried installing again the window got stuck at 'Updating Battle.net Update Agent" at approx 40-50% of the bar. Then after another few dozen tries it changed to showing " BLZBNTAGT000008FC" error after being stuck on 40-50% of Updating Battle.net Update Agent.

Now, I’ve been searching the forums far and wide and some things.
I’ve killed agent.exe before trying again.
I’ve cleared all temporary folders from Battle.net and Blizzard Entertainment folders.
I’ve cleared %ProgramData%.
I’ve reset WMI repository - which is recommended for shown error.
I’ve tried using no antivirus (honestly having to uninstall it instead of adding something to exceptions should never be required).

Nothing helped. I did try to rollback entire Windows10 back to yesterday before I started trying to download HOTS, but all I got now is “Required application data could not be found” system error.

So now I can’t play Starcraft II that was working perfectly before I tried to have fun with friends in HOTS and I am left with nothing but a broken Battle.net desktop app that seems to be beyond possibility of repair.

Is there anything I could try?

2 Likes

Hey there Tcional,

Thank you for taking the time to reach out with these details! This behavior with the Battle.net Desktop App typically indicates that the installation is being corrupted by an underlying issue with the Windows installation. In rarer cases can be caused by a network-related issue. Many potential problems related to your installation of Windows can be resolved by creating a new administrator account, logging into it, and trying the game there.

If the installation only works on the new admin account, this could indicate damaged or missing Windows system files or an issue with how the old user account is configured. This is somewhat common, and the easiest fix is to move any user-specific files that you wish to keep from the old user account to the new admin account. You can also work with Microsoft’s Support to troubleshoot the problem with the old account if preferred.

If the same behavior occurs on the new admin account, can you temporarily test an alternate network such as a mobile hotspot or VPN? This will help us quickly determine whether the issues are network-related.

If the issue is resolved when using an alternate network, at that point we can be sure that the issue is isolated to the primary network. In these situations, ultimately we can only recommend contacting the Internet Service Provider (ISP) for assistance determining what is causing the issue to occur on that specific network. They might need to adjust network-level security/firewall settings or temporarily replace the network devices in your home to narrow it down further. I always recommend requesting to be forwarded to a “level 2 or level 3 technician” when contacting the ISP since the front-line representatives typically only have access to basic diagnostics and troubleshooting tools.

I hope this helps narrow it down! Let us know if you have any questions going forward.

It definitely helped narrowing it down, because neither of these worked.
What else do we have on the table?

At least I managed to get Starcraft II working again by rollbacking Windows (I don’t know if it was necessary, I just did remember that way of launching games after trying a rollback) and launching it through .exe files (at least until it get’s patched).

Same thing is happening to me. It’s been months since i fired up the app and from what i see it changed a lot. Tried to update but got stuck. Uninstalled the app, download a new one and now it’s giving me the same error code. Help us blizzard!

Can we expect any further help on the matter or should I open a support ticked and give them a link to this thread?

Was going to buy Wow, and maybe even get into Starcraft again to play with friends, but I can’t get this horsecrap DRM to install. I’ll just stick with Steam/Origin/GOG/Epic…even fricking amazon Games app at least INSTALLS.
So Blizz, I’ve hated you for a good many years. Most of us do. Keep on doing what you do.

1 Like