completely unusable

I can’t play any game because the app always has some sort of issues. It all happened when I opened Warzone, and when the game opened it said “Game has an update. Please update via the launcher.” After closing the game, client says there is no update for Warzone. I click check for updates, and its stuck like that for hours. I restart the app, and I click scan and check for repairs, it’s stuck at 0%. I delete all the .idx and data.x files in the data folder (to solve this problem), it says there’s an update this time but when I click it, it says waiting on another update (it’s the only update, the only other game I have is Overwatch). I delete the and blizzard entertainment folder in %programdata%, restarting the client says Blizzard Agent went to sleep, trying to wake it up for days. I’ve tried re-installing the client, re-installing the games, updating drivers, using a VPN, disabling antivirus, scanning for malware, every single solution the internet has to offer. would like to add that I’ve tried changing regions as well. The client and Warzone have worked in the past, it only started occuring 2 weeks ago. And yet, after 2 weeks, nothing has worked. I talked with support, and they just made me repeat all the steps that I have done. PLEASE HELP!

1 Like

Im having the same issue. Tried to update SC2 and did all the steps the suggest. I uninstalled and now can’t reinstall. Same problems but on my MAC. Would love to get this issue resolved, seems to be happening to more and more people.