Authenticator "isn't available for your device"

I was trying to download the authenticator app to my phone and when I search the Play Store I get a message saying: “Looking for Authenticator? This app isn’t available for your device because it was made for an older version of Android.”

I’ve done some searching on this and I think it has something to do with a recent Samsung update that was pushed out, so it’s blocking some apps from the store that aren’t updated to work with it. Is there any resolution to this? Posting phone information below.

Phone Make: Samsung
Model: Galaxy S20 5G UW
Android Version: 13


I’m having the same issue, I have an open ticket trying to figure it out. In my case, my physical authenticators battery is dying, and I’m trying to migrate to the app. Here’s the response I got at first.

"I’m Game Master Rynmosend at your service - I’m one of the specialist technical support Game Masters at Blizzard. Thanks for getting in touch and letting us know about you wanting to keep your authenticator active.

The correct step would indeed be to switch to the mobile authenticator. I do want to apologize for the confusion here, as we have recently moved the authenticator into our App for mobile devices. "

I got the app as directed, but still I end up in the play store with the unsupported device message once I tap on the authenticator section within the app

Yeah, I don’t think the Authenticator in the app is working the way they thought it would. When I click “Authenticator” from the menu in the app, it just takes me to the Play Store to download the app (but never gives an option to download, just says “This app isn’t available for your device because it was made for an older version of Android”). I’m stuck in a loop it feels like right now.

1 Like

I got a response from my ticket, here is the reply:

" I want to apologize for giving you incorrect information. The Authenticator is not yet integrated into the App. We are however aware of Android users on newer Android devices being unable to download the Authenticator and are working on a fix for this.

I hope this fix will be available soon, and I wish you a nice day."

At least they are aware of the issue and we’re not alone


Thanks for letting us know, Csontos. I was trying to figure out why I could not make it work for like half an hour! lol

Csontos, thank you for sharing <3 that’s all I wanted to know.

Even stranger, i have two samsung s23 and it works on one but not the other, here is what i got from support:

I’m Technical Specialist Zeadom! I read here when attempting to install the Authenticator on your Samsung s23 ultra you are met with the message, “This app isn’t available for your device because it was made for an older version of Android”

I certainly understand how frustrating and a bit confusing this would be to run into. I will do my best to explain what is going on here! Investigating this issue we are seeing what appears newer Android 13 users reporting this error. With your data along with others we have escalated this issue to our QA and Developers to be investigated.

We look forward to getting this resolved as quickly as possible! Thank you again for taking the time to report this issue to us.

1 Like

My phone is only on Android 11 and still can’t get this. Now that my physical authenticator’s battery has died - so I had to request that it be unattached, I feel like my account is left rather naked and unsecure. :frowning: It would be great if they would just support standard authenticators and/or hard tokens already established in the market.

Yep I agree they need to allow us to use other authenticator apps at least until they fix this issue. I’m running Android 12 on my newer phone and it won’t let me download the app. Yet my secondary phone which runs Android 9 lets me download it with no issues. I know I can download the APK and it’ll work but most of the sites that “offer” a download look really shifty and I don’t want to download something extra with the APK lol.

What we had to do was take a backup of the apk from my phone and use that apk backup to install it on the phone that says “cant install due to it being an older version of android” worked just fine like this. Kind of a stupid work around though.

This is a fantastic idea, what did you use to make the backup?

i typed in on google download wow authenticator and it let me click install and install it

Got same problem today (dying battery in HardWare’s authenticator), but in my case solution was to update battlenet mobile app which has authenticator included. now, when im going to log in to battlenet site or PC app, it asks me to confirm that move via mobile battlenet app.
problem solved.

Is anyone else having issues with the app not available on App Store? I have that problem