Battle.net app not signing in #BLZBNTBGS80000011

BLZBNTBGS80000011 is the error code i’m receiving and says “We couldn’t log you in to Battle.net” and then gives me the option to login offline.

This seems to be a common error code and I’m yet to find a solution through many forum posts, google, reddit, Youtube etc.

I’ve deleted and re-installed the app many times, re-established by authenticator, reset router, released, renewed and flushed DNS/cache, reset many other command prompts, excluded battle.net through my firewall and tried switching it off, tried changing region upon sign-in, drivers all up to date, disabled start-up programs in task manager and reset incase of conflicting software.

At this point i’m not sure what else to try. I have also tried signing into my second account which has the same issue to eliminate any possibility that it might be account related for whatever reason.

Any suggestions would be greatly appreciated:) Thankyou

–Edit-- Upon further troubleshooting, it signs in when I connect my PC to my phone personal hotspot, not sure where to go from here though

1 Like

Your other network is likely blocking the Bnet client or game traffic. What kind of connection is it?

1 Like

It’s huawei wifi network and I have never had problems with it before so i’m not sure what’s changed to make this occur

Are you using a wireless carrier as your ISP? Like T-Mobile, Verizon, or another carrier. Or are you using a landline cable/fiber connection?

1 Like

I believe it’s a wireless carrier

All of Blizzard’s software, except the mobile games/clients, list a landline connection as the minimum requirement. Many wireless carriers deprioritize any traffic related to gaming because it creates network congestion that affects the quality of service for other customers who are trying to upload a photo or stream a quick video.

1 Like

I have the same thing. There is no solution

I am getting the same error message. Only this has happened to me twice where the only other solution was to reinstall windows. No troubleshooting or anything on forums and sites provided any way to get any assistance.
I use spectrum cable as my provider and have no problems playing games, but then every once in a while Ill change games and then this issue happens. Its so frustrating that I’m literally in a game and between swapping games get told that I’ve lost connect and not be able to play anything until I reinstall. I’ve tried the troubleshooting steps they provide and get nothing. All the while if i login on my laptop I get connection no problem but the desktop has this issue. (There is also nothing being blocked on the firewalls for battlenet or anything of that nature as its only happens between switching games)

yep wont let me long in either kicked me offline in middle of game also

same thing for me, does anyone admin watch this topic or have any idea? is it a ddos from others players? are we getting compensation?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.