App crashes on startup

I cannot start the Battle.Net app. Every time i start it i get the crash reporter saying there’s an error before it gets anywhere. The error logs show the following:

KERN_INVALID_ADDRESS at 0x0000000000000000
Thread 0x00000307 "CrBrowserMain" [Stack Base: 0x00000000e5f03000 Used Space: 10056/8388608 bytes]
  0 0x00007FFF2F22C6CB ""             CFArrayGetCount + 6

I tried deleting the app, all of its settings in ~/Library/Application\ Support, and Preferences, as well as the /Users/Shared as per the support sites. Then reinstalled from a fresh download (after a reboot to be sure), but still the same.

I am still on Mac OS 10.15.7 on a MacBook Pro 15in with touchbar as I cannot upgrade to MacOS 11 due to other application requirements.

Anyone have any ideas?


Found the issue. I have a iKKEGOL USB footswitch I use for voice chat push to talk. As soon as i plug it in, the launcher crashes immediately after a spinning beach ball for a couple seconds and any startup attempt crashes while it’s plugged in.