Authenticator will not setup

I tried looking for other posts that have the same problem. I can’t find out what the problem is either than the app refuses to setup. I am unable to even add my only phone number onto my account.
I have tried to contact support unsuccessfully multiple time.
Why is Blizzard making it next to impossible for anyone to play their games any more? I’m tired of their pettiness.

1 Like

I am having the exact same problem. Per GM Denvorer, there is no support for this app at all, so there’s no one to ask for help. So basically, any issues with this app at all and you’re out of luck. If anyone finds out a fix, I hope they post it. Kinda sad that your best chance at getting anything fixed at Blizzard is to hope another gamer knows a fix or work around.

I don’t have the numbers, but I believe that this issue would effect 10s of thousands of accounts. It has to do with their phone number scanner. This denies people from playing the free games like COD, or securing their accounts with the authenticator.